Force symlink creation.
[openwrt/svn-archive/archive.git] / net / nfs-utils / Makefile
index 7fd9e729f337c06c9846399089cd5b44a71d5d76..6dd33dbb82196b6f68ded9a9a40165ebbb179998 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nfs-utils
-PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.1.2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.sourceforge.net/nfs/
-PKG_MD5SUM:=df88c6fe88a26f9797e74cb2d3291a2a
+PKG_MD5SUM:=76ee9274c2b867839427eba91b327f03
 
 PKG_BUILD_DEPENDS:=libgssapi librpcsecgss libnfsidmap libwrap
 
@@ -38,6 +38,8 @@ endef
 
 CONFIGURE_ARGS += --disable-gss
 TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Build/Compile
        $(call Build/Compile/Default, \
                OPT="$(TARGET_CFLAGS)" \
@@ -49,7 +51,8 @@ endef
 
 define Package/nfs-utils/install
        $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount* $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount.nfs $(1)/sbin/
+       (cd $(1)/sbin; ln -sf mount.nfs mount.nfs4; ln -sf mount.nfs umount.nfs; ln -sf mount.nfs umount.nfs4)
 endef
 
 $(eval $(call BuildPackage,nfs-utils))