fixes samba3 to use gawk instead of mawk
[openwrt/svn-archive/archive.git] / net / ngrep / Makefile
index fbc6714e5a327444e76b3285ce1de653bccb5776..c2c3edb1ac11d4f4a03ed086a0f58256ddf6fd00 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ngrep
 PKG_MD5SUM:=bc8150331601f3b869549c94866b4f1c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,16 +23,18 @@ define Package/ngrep
   CATEGORY:=Network
   DEPENDS:=+libpcap +libpcre
   TITLE:=network grep
-  DESCRIPTION:=\
-       ngrep a pcap-aware tool that will allow you to specify extended\\\
-       regular expressions to match against data payloads of packets. It\\\
-       currently recognizes TCP, UDP, and ICMP across Ethernet, PPP, SLIP,\\\
-       FDDI, Token Ring and null interfaces, and understands BPF filter\\\
-       logic in the same fashion as more common packet sniffing tools,\\\
-       like tcpdump and snoop.
   URL:=http://ngrep.sourceforge.net
 endef
 
+define Package/ngrep/description
+       ngrep a pcap-aware tool that will allow you to specify extended
+       regular expressions to match against data payloads of packets. It
+       currently recognizes TCP, UDP, and ICMP across Ethernet, PPP, SLIP,
+       FDDI, Token Ring and null interfaces, and understands BPF filter
+       logic in the same fashion as more common packet sniffing tools,
+       like tcpdump and snoop.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-pcap-includes=$(STAGING_DIR)/usr/include \