update nmap to 4.20 (patch by jens muecke)
[openwrt/svn-archive/archive.git] / net / nmap / Makefile
index 9eacdcbc0f5f7858b5b8e02fed5a00d2b4afd1c0..0670c09bab896abbd4586dd4735b745a8222e7d0 100644 (file)
@@ -9,10 +9,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nmap
-PKG_VERSION:=4.01
+PKG_VERSION:=4.20
 PKG_RELEASE:=1
 
-PKG_MD5SUM:=09c259837b24f6c7385c2c1c49760a7c
+PKG_MD5SUM:=ea50419f99472200c4184a304e3831ea
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
 PKG_CAT:=bzcat
@@ -53,9 +53,9 @@ define Build/Compile
 endef
 
 define Package/nmap/install    
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/nmap $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/share/nmap
+       $(INSTALL_DIR) $(1)/usr/share/nmap
        for file in mac-prefixes os-fingerprints protocols rpc service-probes services; do \
                $(CP) $(PKG_INSTALL_DIR)/usr/share/nmap/nmap-$$$$file $(1)/usr/share/nmap/ ; \
        done