Rename patches to match conventions, second round; *ouch*
[openwrt/svn-archive/archive.git] / net / nocatsplash / Makefile
index 2dd588425709d7d81d988501047068e88f499b83..d147681b94dc1a1e95b6c24c7fa866a30a2d13aa 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=nocatsplash
 PKG_VERSION:=0.92
 PKG_RELEASE:=1
 PKG_NAME:=nocatsplash
 PKG_VERSION:=0.92
 PKG_RELEASE:=1
-PKG_MD5SUM:=e0fcc0effe52e63bc31070d16d0b4a81
 
 
-PKG_SOURCE_URL:=http://wifi.rulez.org/~josephus/
 PKG_SOURCE:=NoCatSplash-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=NoCatSplash-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://wifi.rulez.org/~josephus/
+PKG_MD5SUM:=e0fcc0effe52e63bc31070d16d0b4a81
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/NoCatSplash-$(PKG_VERSION)
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/NoCatSplash-$(PKG_VERSION)
@@ -25,14 +25,15 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nocatsplash
   SECTION:=net
   CATEGORY:=Network
 define Package/nocatsplash
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+glib
+  DEPENDS:=+glib1
   TITLE:=Open public network gateway daemon
   TITLE:=Open public network gateway daemon
-  DESCRIPTION:=NoCatSplash is an Open Public Network Gateway Daemon.\\\
-       It performs as a [captive/open/active] portal. When run on a gateway/router\\\
-       on a network, all web requests are redirected until the client either logs\\\
-       in or clicks "I Accept" to an AUP. The gateway daemon then changes the\\\
-       firewall rules on the gateway to pass traffic for that client (based on IP\\\
-       address and MAC address).\\\
+  DESCRIPTION:=\
+       NoCatSplash is an Open Public Network Gateway Daemon.\\\
+       It performs as a [captive/open/active] portal. When run on a gateway/router \\\
+       on a network, all web requests are redirected until the client either logs \\\
+       in or clicks "I Accept" to an AUP. The gateway daemon then changes the \\\
+       firewall rules on the gateway to pass traffic for that client (based on IP \\\
+       address and MAC address).
   URL:=http://nocat.net
 endef
 
   URL:=http://nocat.net
 endef
 
@@ -41,8 +42,10 @@ define Package/nocatsplash/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,        --with-firewall=iptables \
-                 --with-glib-prefix="$(STAGING_DIR)/usr")
+       $(call Build/Configure/Default, \
+               --with-firewall=iptables \
+               --with-glib-prefix="$(STAGING_DIR)/usr" \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
@@ -53,7 +56,7 @@ define Build/Compile
 endef
 
 define Package/nocatsplash/install     
 endef
 
 define Package/nocatsplash/install     
-       mkdir -p $(1)
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
 endef