nodogsplash: mkinstalldirs script does not exist. Just use $(INSTALL_DIR).
[openwrt/svn-archive/archive.git] / net / nodogsplash / Makefile
index 23ecbb5bfd0f7a9e9317ca58bf762cc462524242..486cdf856c60df7109f9a4c8e33cb0aceff5aa97 100644 (file)
@@ -1,39 +1,40 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.8_beta1
+PKG_VERSION:=0.9_beta9.9.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/
-PKG_MD5SUM:=f81c69ea46d61455b394f237bcdb3fe4
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/ \
+       http://kokoro.ucsd.edu/nodogsplash/old/
+PKG_MD5SUM:=3ba0d862b4d63ecf97f16176a486faed
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nodogsplash
+  SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +iptables-mod-ipopt
   TITLE:=Open public network gateway daemon
-  DESCRIPTION:=\
-       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an\\\
-       internet connection. It is intended for use on wireless access points running OpenWRT\\\
-       (but may also work on other Linux-based devices).
   URL:=http://kokoro.ucsd.edu/nodogsplash/
 endef
 
+define Package/nodogsplash/description
+       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an
+       internet connection. It is intended for use on wireless access points running OpenWRT
+       (but may also work on other Linux-based devices).
+endef
+
 define Build/Configure
        $(call Build/Configure/Default,\
                --enable-static \
@@ -41,19 +42,28 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/usr/{share{,/doc/$(PKG_NAME)-$(PKG_VERSION)},lib,include{,/nodogsplash},bin,sbin}/
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               mkinstalldirs="$(SHELL) $(PKG_BUILD_DIR)/config/mkinstalldirs" \
+               mkinstalldirs="$(INSTALL_DIR)" \
                install
 endef
 
-define Package/nodogsplash/install     
+define Package/nodogsplash/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME)/
+       $(SED) 's,br0,br-lan,' $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
+       $(CP) $(PKG_BUILD_DIR)/htdocs $(1)/etc/$(PKG_NAME)/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "imq"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "ipt_IMQ"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "sch_htb"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,nodogsplash))