[package] add missing cross-compilation patch from #5468, thanks swalker
[openwrt/svn-archive/archive.git] / net / nodogsplash / Makefile
index 5cb4fe97340b3529795e3a094a95a18b5bd8fcb6..d21a299b955d4d4963d00fbcc6fafdfb6b141b7f 100644 (file)
@@ -4,22 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.9_beta8
-PKG_RELEASE:=1
+PKG_VERSION:=0.9_beta9.9
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/ \
        http://kokoro.ucsd.edu/nodogsplash/old/
-PKG_MD5SUM:=74269856452b9ef6d8719a6b46bae56d
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=96e597977717610186ed09ebd7fa54cf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,13 +24,15 @@ define Package/nodogsplash
   CATEGORY:=Network
   DEPENDS:=+libpthread
   TITLE:=Open public network gateway daemon
-  DESCRIPTION:=\
-       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an\\\
-       internet connection. It is intended for use on wireless access points running OpenWRT\\\
-       (but may also work on other Linux-based devices).
   URL:=http://kokoro.ucsd.edu/nodogsplash/
 endef
 
+define Package/nodogsplash/description
+       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an
+       internet connection. It is intended for use on wireless access points running OpenWRT
+       (but may also work on other Linux-based devices).
+endef
+
 define Build/Configure
        $(call Build/Configure/Default,\
                --enable-static \
@@ -53,9 +50,14 @@ endef
 
 define Package/nodogsplash/install     
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME)/
+       $(CP) $(PKG_BUILD_DIR)/htdocs $(1)/etc/$(PKG_NAME)/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/
 endef
 
 $(eval $(call BuildPackage,nodogsplash))