use kill $(cat /var/run/sshd.pid) instead of killall sshd to
[openwrt/svn-archive/archive.git] / net / nprobe / Makefile
index daa8b498f63143543f7042f99621a705f1650a6f..66f591670d968849430d4890a297e9102a8ef05b 100644 (file)
@@ -1,40 +1,50 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nprobe
 PKG_VERSION:=4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=nProbe-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
 PKG_MD5SUM:=32ed12f60eab771a79bd5f90622fa2a3
-PKG_CAT:=zcat
 
 BUILD_DEPENDS:=libwrap
+PKG_FIXUP:=libtool
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/nProbe
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nprobe
-       SECTION:=utils
-       CATEGORY:=Utilities
-       DEPENDS:=+libpcap +libpcre +libpthread +libwrap
-       TITLE:=nProbe
-       URL:=http://invisible-island.net/dialog/
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libpcap +libpcre +libpthread +NPROBE_MYSQL_SUPPORT:libmysqlclient
+  TITLE:=nProbe
+  URL:=http://invisible-island.net/dialog/
+endef
+
+define Package/nprobe/config
+       config NPROBE_MYSQL_SUPPORT
+               depends on PACKAGE_nprobe
+               bool "MySQL support"
+
 endef
 
 define Package/nprobe/description
                nprobe
 endef
 
+ifndef CONFIG_NPROBE_MYSQL_SUPPORT
+  CONFIGURE_VARS += ac_cv_prog_MYSQL=no
+endif
+
 define Build/Configure
        # patch creates these, so we make them executable
        chmod +x $(PKG_BUILD_DIR)/configure
@@ -57,7 +67,7 @@ define Package/nprobe/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nprobe \
                $(1)/usr/bin/
-       $(CP) -a $(PKG_INSTALL_DIR)/usr/lib/* \
+       $(CP) -a $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib
 endef