nuke $Id$ in /packages as well
[openwrt/svn-archive/archive.git] / net / nsca / Makefile
index 59736ecb8603555e08f1a4b715b9ada101da345d..4809fde6029d22d8e05fbfeca6ccf45ecf61a834 100644 (file)
@@ -4,20 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nsca
-PKG_VERSION:=2.6
+PKG_VERSION:=2.7.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=d526a3ac3c29648c729c5fb4fb332488
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=33a98e7975f633a9489d7a8938ed6131
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,12 +25,20 @@ define Package/send-nsca
   URL:=http://www.nagios.org/
 endef
 
+define Package/send-nsca/description
+       This is the client program that is used to send service check
+       information from a remote machine to the nsca daemon on the central
+       machine that runs Nagios.
+endef
+
 define Package/send-nsca/conffiles
 /etc/send_nsca.cfg
 endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
+               --with-nsca-user="root" \
+               --with-nsca-grp="root" \
                --with-libmcrypt-prefix="$(STAGING_DIR)/usr" \
                , \
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
@@ -48,7 +52,7 @@ endef
 
 define Package/send-nsca/install
        $(INSTALL_DIR) $(1)/etc
-       install -m0600 $(PKG_BUILD_DIR)/sample-config/send_nsca.cfg $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/sample-config/send_nsca.cfg $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/send_nsca $(1)/usr/sbin/
 endef