fix asterisk 1.6.x compile on powerpc
[openwrt/svn-archive/archive.git] / net / nsca / Makefile
index 3fc3c4715c7420be836de20ddf5b3397283dfecd..8a07b2019b5946f257c8919b40634c4c0cfa9dec 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nsca
-PKG_VERSION:=2.6
+PKG_VERSION:=2.7.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=d526a3ac3c29648c729c5fb4fb332488
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=33a98e7975f633a9489d7a8938ed6131
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,12 +26,20 @@ define Package/send-nsca
   URL:=http://www.nagios.org/
 endef
 
+define Package/send-nsca/description
+       This is the client program that is used to send service check
+       information from a remote machine to the nsca daemon on the central
+       machine that runs Nagios.
+endef
+
 define Package/send-nsca/conffiles
 /etc/send_nsca.cfg
 endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
+               --with-nsca-user="root" \
+               --with-nsca-grp="root" \
                --with-libmcrypt-prefix="$(STAGING_DIR)/usr" \
                , \
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \