[net] Monitoring: Finally collected a Nagios programs under Monitoring submenu.
[openwrt/svn-archive/archive.git] / net / nsca / Makefile
index 3fc3c4715c7420be836de20ddf5b3397283dfecd..cf596cb2adcfc10d201fb57fcfee719cdd99322e 100644 (file)
@@ -4,37 +4,42 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nsca
-PKG_VERSION:=2.6
+PKG_VERSION:=2.7.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=d526a3ac3c29648c729c5fb4fb332488
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=33a98e7975f633a9489d7a8938ed6131
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/send-nsca
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Monitoring
   DEPENDS:=+libmcrypt
   TITLE:=Nagios Service Check Acceptor (NSCA) client
   URL:=http://www.nagios.org/
 endef
 
+define Package/send-nsca/description
+       This is the client program that is used to send service check
+       information from a remote machine to the nsca daemon on the central
+       machine that runs Nagios.
+endef
+
 define Package/send-nsca/conffiles
 /etc/send_nsca.cfg
 endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
+               --with-nsca-user="root" \
+               --with-nsca-grp="root" \
                --with-libmcrypt-prefix="$(STAGING_DIR)/usr" \
                , \
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \