[packages] Various Makefile cleanups.
[openwrt/svn-archive/archive.git] / net / ntpd / Makefile
index 81280db821009d9b951594993fca8ea7626dd6d9..52ce60c6b5c491ace1be9186e7489fdd69cc28a2 100644 (file)
@@ -1,22 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
-PKG_VERSION:=4.2.4p6
-PKG_RELEASE:=2
+PKG_VERSION:=4.2.4p7
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
-PKG_MD5SUM:=1961c2c12b66b9046d5df37d0a41b181
+PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
+PKG_MD5SUM:=8c19ff62ed4f7d64f8e2aa59cb11f364
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
@@ -57,7 +55,7 @@ endef
 
 define Package/ntp-utils
   $(call Package/ntpd/Default)
-  DEPENDS:=+libreadline +libncurses
+  DEPENDS:=+libncurses
   TITLE+= utilities
 endef
 
@@ -99,7 +97,7 @@ define Build/Configure
                --enable-NMEA \
                --enable-LOCAL-CLOCK \
                --enable-SHM \
-               --enable-linuxcaps, \
+               --disable-linuxcaps, \
                ac_cv_lib_rt_sched_setscheduler=no \
        )
 endef