packages: Use OpenWrt ntp vendor pool in default configs. (Cleaned whitespace too.)
[openwrt/svn-archive/archive.git] / net / ntpd / Makefile
index 9b7bea42504d22204c56f7d72359b68332a892e2..5919a7a1765e2f2d3f7da736209b7ea592c67f56 100644 (file)
@@ -9,14 +9,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
-PKG_VERSION:=4.2.4
-PKG_RELEASE:=1
+PKG_VERSION:=4.2.4p4
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
-PKG_MD5SUM:=eb9147d26cbe18bd8fbec07f1df55aef
+PKG_MD5SUM:=fcb32a01e1ae3f9ed5bac86b12c7a1cc
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,13 +44,15 @@ echo "ntp             123/udp     # Network Time Protocol
 ntp             123/tcp     # Network Time Protocol" >> $${IPKG_INSTROOT}/etc/services
 endef
 
 ntp             123/tcp     # Network Time Protocol" >> $${IPKG_INSTROOT}/etc/services
 endef
 
+TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libelf
+
 define Build/Configure
        $(call Build/Configure/Default, \
 define Build/Configure
        $(call Build/Configure/Default, \
-                --disable-all-clocks \
+               --disable-all-clocks \
                --disable-parse-clocks \
                --disable-parse-clocks \
-                --enable-NMEA \
+               --enable-NMEA \
                --enable-LOCAL-CLOCK \
                --enable-LOCAL-CLOCK \
-                --enable-SHM \
+               --enable-SHM \
                --enable-linuxcaps \
        )
 endef
                --enable-linuxcaps \
        )
 endef