move the drift file to /tmp since it gets written a fair amount, bump release and...
[openwrt/svn-archive/archive.git] / net / ntpd / Makefile
index bf86ae868aabaeb05420a14278c5e2096b58458a..62995d06a8377025f6c6f1b22aa88dd30a9b7bb4 100644 (file)
@@ -9,15 +9,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
-PKG_VERSION:=4.2.4
-PKG_RELEASE:=1
+PKG_VERSION:=4.2.4p4
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
-PKG_MD5SUM:=eb9147d26cbe18bd8fbec07f1df55aef
-PKG_CAT:=zcat
+PKG_MD5SUM:=fcb32a01e1ae3f9ed5bac86b12c7a1cc
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -44,13 +44,15 @@ echo "ntp             123/udp     # Network Time Protocol
 ntp             123/tcp     # Network Time Protocol" >> $${IPKG_INSTROOT}/etc/services
 endef
 
+TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libelf
+
 define Build/Configure
        $(call Build/Configure/Default, \
-                --disable-all-clocks \
+               --disable-all-clocks \
                --disable-parse-clocks \
-                --enable-NMEA \
+               --enable-NMEA \
                --enable-LOCAL-CLOCK \
-                --enable-SHM \
+               --enable-SHM \
                --enable-linuxcaps \
        )
 endef