packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / nzbget / Makefile
index b7b20972bc180dcbe0e75af4771df9ec8d0e3b9c..f1bc886498699aece96e1c5bca6fc49a8a0c1023 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nzbget
-PKG_VERSION:=0.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.7.0
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nzbget
-PKG_MD5SUM:=eb95b3930abffb570e37af8d284c1f9d
+PKG_MD5SUM:=27971846aba75f5e312d80dce7edbc5d
 
 PKG_FIXUP:=libtool
 
@@ -23,11 +23,13 @@ TARGET_LDFLAGS+=-Wl,-rpath-link="$(STAGING_DIR)/usr/lib"
 TARGET_CFLAGS += $(FPIC)
 
 define Package/nzbget
+  SUBMENU:=NNTP
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libxml2 +libpar2 +libopenssl +libpthread
+  DEPENDS:=+libxml2 +libpar2 +libopenssl +libpthread +libncurses
   URL:=http://nzbget.sourceforge.net/
-  TITLE:=Binary newsgrabber
+  TITLE:=Binary newsgrabber for nzb-files
+  MAINTAINER:=Artur Wronowski <arteqw@gmail.com>
 endef
 
 define Package/nzbget/description
@@ -37,7 +39,6 @@ endef
 CONFIGURE_ARGS += \
        --disable-static \
        --disable-nls \
-       --disable-curses \
        --with-tlslib=OpenSSL \
        --with-libpar2-includes=$(STAGING_DIR)/usr/include/libpar2 \
        --with-libpar2-libraries=$(STAGING_DIR)/usr/lib \
@@ -45,6 +46,8 @@ CONFIGURE_ARGS += \
        --with-libsigc-libraries=$(STAGING_DIR)/usr/lib \
        --with-openssl-includes=$(STAGING_DIR)/usr/include \
        --with-openssl-libraries=$(STAGING_DIR)/usr/lib \
+       --with-libcurses-includes=$(STAGING_DIR)/usr/include \
+       --with-libcurses-libraries=$(STAGING_DIR)/usr/lib \
        , \
        PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
 
@@ -66,4 +69,8 @@ define Package/nzbget/install
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/nzbget.conf.example $(1)/etc/nzbget.conf
 endef
 
+define Package/nzbget/conffiles
+/etc/nzbget.conf
+endef
+
 $(eval $(call BuildPackage,nzbget))