replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / oidentd / Makefile
index 45bf9b4e6eee3377aefdeb046df2390f26ee5fb4..5aa4ae88a1bdc611b7b11f1dd1cfb9ae6ad04a48 100644 (file)
@@ -37,9 +37,9 @@ define Build/Compile
 endef
 
 define Package/oidentd/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef