Now move tcp_wrappers to libs
[openwrt/svn-archive/archive.git] / net / oidentd / Makefile
index 64a8305b15844b38b0e3c7c9f3b7e0950052bdac..edbe0f4596c36749b41195fcaad478307663ba02 100644 (file)
@@ -4,50 +4,43 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oidentd
 PKG_VERSION:=2.0.8
 PKG_RELEASE:=1
-PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
 
-PKG_SOURCE_URL:=@SF/ojnk
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/ojnk
+PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
 PKG_CAT:=zcat
 
-
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/oidentd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
   TITLE:=Identd server 
-  DESCRIPTION:=A nat aware identd server that will correctly forwared requests to clients
+  DESCRIPTION:=\
+       A nat aware identd server that will correctly forwared requests to clients.
+  URL:=http://dev.ojnk.net/
 endef
 
-
-define Build/Configure
-  $(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
-endef
+# uses GNU configure
 
 define Build/Compile
-  $(call Build/Compile/Default,all)
+       $(call Build/Compile/Default,all)
 endef
 
 define Package/oidentd/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 -d $(1)/etc/init.d
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
-       $(CP) ./files/S85oidentd $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/oidentd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef
 
 $(eval $(call BuildPackage,oidentd))
-
-
-