[packages] libart: update to 2.3.21
[openwrt/svn-archive/archive.git] / net / oidentd / Makefile
index b951305ce1d6b90dbb062ab6f1002f030a6e8371..ef604315bdff7e9af553ffe2acf2db1307702afe 100644 (file)
@@ -4,50 +4,41 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oidentd
 PKG_VERSION:=2.0.8
 PKG_RELEASE:=1
-PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
 
-PKG_SOURCE_URL:=@SF/ojnk
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/ojnk
+PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/oidentd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
   TITLE:=Identd server 
-  DESCRIPTION:=A nat aware identd server that will correctly forwared requests to clients
+  URL:=http://dev.ojnk.net/
 endef
 
-
-define Build/Configure
-  $(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
+define Package/oidentd/description
+       A nat aware identd server that will correctly forwared requests to clients.
 endef
 
+# uses GNU configure
+
 define Build/Compile
-  $(call Build/Compile/Default,all)
+       $(call Build/Compile/Default,all)
 endef
 
 define Package/oidentd/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 -d $(1)/etc/init.d
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
-       $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/oidentd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef
 
 $(eval $(call BuildPackage,oidentd))
-
-
-