Add nufw
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index 0f859b3914c5d436885bb730cd411c913e460740..1629957f8cd4578597828ecfeeaa355b8745e24d 100644 (file)
@@ -9,30 +9,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
-PKG_VERSION:=3.7p1
-PKG_RELEASE:=1
-PKG_MD5SUM:=10ed8eefd760e5819efcf3277b118f47
+PKG_VERSION:=3.9p1
+PKG_RELEASE:=2
 
-# space separated list or special @SF for sourceforge projects
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenNTPD/ \
        ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.sunet.se/pub/OpenBSD/OpenNTPD/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_MD5SUM:=afc34175f38d08867c1403d9008600b3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openntpd
+  SUBMENU:=Time Synchronization
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=A free and easy to use NTP (Network Time Protocol) implementation
-  DESCRIPTION:=NTP server
+  TITLE:=NTP server
   URL:=http://www.openntpd.org/
 endef
 
+define Package/openntpd/description
+       A free and easy to use NTP (Network Time Protocol) implementation.
+endef
+
 define Package/openntpd/conffiles
 /etc/ntpd.conf
 endef
@@ -75,24 +77,27 @@ grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
 endef
 
 define Build/Configure
-$(call Build/Configure/Default, --with-builtin-arc4random \
+       $(call Build/Configure/Default, \
+               --with-builtin-arc4random \
                --with-privsep-user=ntp \
-               --with-adjtimex)
+               --with-adjtimex \
+       )
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DUSE_ADJTIMEX"
 endef
 
 define Package/openntpd/install        
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/ntpd.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/ntpd.init $(1)/etc/init.d/ntpd
-       install -d -m0755 $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/ntpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/ntpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ntpd.init $(1)/etc/init.d/ntpd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_BIN) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
 endef
 
 $(eval $(call BuildPackage,openntpd))