escape '$' in openntpd postinst template
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index 84375afcf99b3e47d27c7f4becdb56ff2aa07770..35c199431935cac381cdf5a953811683788ea1e0 100644 (file)
@@ -45,10 +45,10 @@ id=50
 
 # do not change below
 # check if we are on real system
-if [ -z "${IPKG_INSTROOT}" ]; then
+if [ -z "$${IPKG_INSTROOT}" ]; then
         # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $5 }'`
-        if [ "$rootfs" = "squashfs" ]; then
+        rootfs=`mount |awk '/root/ { print $$5 }'`
+        if [ "$$rootfs" = "squashfs" ]; then
                 if [ -h /etc/group ]; then
                         rm /etc/group
                         cp -p /rom/etc/group /etc/group
@@ -61,17 +61,17 @@ if [ -z "${IPKG_INSTROOT}" ]; then
 fi
 
 echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $name to /etc/group"
-        echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+        echo "adding group $$name to /etc/group"
+        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
 fi
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $name to /etc/passwd"
-        echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
+        echo "adding user $$name to /etc/passwd"
+        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 
-grep -q '^ntp[[:space:]]*123/udp' ${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $? -ne 0 ] && echo "ntp       123/udp" >>${IPKG_INSTROOT}/etc/services
+grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
 endef
 
 define Build/Configure