Fix the hotplug script and add a kakikaze config file (#1083)
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index 57b903aa973d0e4458cdacae22406110302556c5..58e2fb773ba41b65b98b0aa3aedc7cd82a3d1e28 100644 (file)
@@ -9,16 +9,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
-PKG_VERSION:=3.7p1
+PKG_VERSION:=3.9p1
 PKG_RELEASE:=1
-PKG_MD5SUM:=10ed8eefd760e5819efcf3277b118f47
 
-# space separated list or special @SF for sourceforge projects
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenNTPD/ \
        ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.sunet.se/pub/OpenBSD/OpenNTPD/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=afc34175f38d08867c1403d9008600b3
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -28,8 +27,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openntpd
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=A free and easy to use NTP (Network Time Protocol) implementation
-  DESCRIPTION:=NTP server
+  TITLE:=NTP server
+  DESCRIPTION:=\
+       A free and easy to use NTP (Network Time Protocol) implementation.
   URL:=http://www.openntpd.org/
 endef
 
@@ -45,10 +45,10 @@ id=50
 
 # do not change below
 # check if we are on real system
-if [ -z "${IPKG_INSTROOT}" ]; then
+if [ -z "$${IPKG_INSTROOT}" ]; then
         # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $5 }'`
-        if [ "$rootfs" = "squashfs" ]; then
+        rootfs=`mount |awk '/root/ { print $$5 }'`
+        if [ "$$rootfs" = "squashfs" ]; then
                 if [ -h /etc/group ]; then
                         rm /etc/group
                         cp -p /rom/etc/group /etc/group
@@ -61,39 +61,41 @@ if [ -z "${IPKG_INSTROOT}" ]; then
 fi
 
 echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $name to /etc/group"
-        echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+        echo "adding group $$name to /etc/group"
+        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
 fi
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $name to /etc/passwd"
-        echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
+        echo "adding user $$name to /etc/passwd"
+        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 
-grep -q '^ntp[[:space:]]*123/udp' ${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $? -ne 0 ] && echo "ntp       123/udp" >>${IPKG_INSTROOT}/etc/services
+grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
 endef
 
 define Build/Configure
-$(call Build/Configure/Default, --with-builtin-arc4random \
+       $(call Build/Configure/Default, \
+               --with-builtin-arc4random \
                --with-privsep-user=ntp \
-               --with-adjtimex)
+               --with-adjtimex \
+       )
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DUSE_ADJTIMEX"
-       touch $@
 endef
 
 define Package/openntpd/install        
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/ntpd.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/ntpd.init $(1)/etc/init.d/S55ntpd
-       install -d -m0755 $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/ntpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/ntpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ntpd.init $(1)/etc/init.d/ntpd
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_BIN) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
 endef
 
 $(eval $(call BuildPackage,openntpd))