[package] kill openntpd harder when stopping, patch from Stefan Monnier
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index 16ce2e1a95dce5f85dea165505a89e5abfd74dde..9640cf5c333717c686b8afdd1009243f24091b93 100644 (file)
@@ -4,13 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
 PKG_VERSION:=3.9p1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
@@ -18,9 +17,6 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.sunet.se/pub/OpenBSD/OpenNTPD/
 PKG_MD5SUM:=afc34175f38d08867c1403d9008600b3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -74,7 +70,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
 fi
 
 grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services || exit 0
 endef
 
 define Build/Configure