Add gw6c and make it link against uclibcxx (#2125)
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index bbbf9dbbdd277b21a59cdef7325479319cedca7c..ba7e847e3da1a303e202ca77bc3b11590a5ca7c1 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
 PKG_VERSION:=3.9p1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
@@ -18,7 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.sunet.se/pub/OpenBSD/OpenNTPD/
 PKG_MD5SUM:=afc34175f38d08867c1403d9008600b3
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -29,11 +28,13 @@ define Package/openntpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=NTP server
-  DESCRIPTION:=\
-       A free and easy to use NTP (Network Time Protocol) implementation.
   URL:=http://www.openntpd.org/
 endef
 
+define Package/openntpd/description
+       A free and easy to use NTP (Network Time Protocol) implementation.
+endef
+
 define Package/openntpd/conffiles
 /etc/ntpd.conf
 endef
@@ -72,7 +73,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
 fi
 
 grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
+[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services || exit 0
 endef
 
 define Build/Configure