[backfire/packages] openntpd: merge r28620, r28621
[openwrt/svn-archive/archive.git] / net / openntpd / Makefile
index bbbf9dbbdd277b21a59cdef7325479319cedca7c..d6c139cc955a689c6a75494aaa7fd439493f4860 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
 PKG_VERSION:=3.9p1
-PKG_RELEASE:=1
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
@@ -18,9 +17,6 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenNTPD/ \
        ftp://ftp.sunet.se/pub/OpenBSD/OpenNTPD/
 PKG_MD5SUM:=afc34175f38d08867c1403d9008600b3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,56 +25,21 @@ define Package/openntpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=NTP server
-  DESCRIPTION:=\
-       A free and easy to use NTP (Network Time Protocol) implementation.
   URL:=http://www.openntpd.org/
 endef
 
-define Package/openntpd/conffiles
-/etc/ntpd.conf
+define Package/openntpd/description
+       A free and easy to use NTP (Network Time Protocol) implementation.
 endef
 
-define Package/openntpd/postinst
-#!/bin/sh
-
-name=ntp
-id=50
-
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp -p /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp -p /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-
-grep -q '^ntp[[:space:]]*123/udp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-[ $$? -ne 0 ] && echo "ntp       123/udp" >>$${IPKG_INSTROOT}/etc/services
+define Package/openntpd/conffiles
+/etc/ntpd.conf
 endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-builtin-arc4random \
-               --with-privsep-user=ntp \
+               --with-privsep-user=network \
                --with-adjtimex \
        )
 endef
@@ -89,8 +50,8 @@ define Build/Compile
 endef
 
 define Package/openntpd/install        
-       $(INSTALL_DIR) $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd $(1)/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/ntpd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -99,4 +60,16 @@ define Package/openntpd/install
        $(INSTALL_BIN) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
 endef
 
+define Package/openntpd/postinst
+#!/bin/sh
+[ -L "$${IPKG_INSTROOT}/usr/sbin/ntpd" ] && rm -f "$${IPKG_INSTROOT}/usr/sbin/ntpd"
+exit 0
+endef
+
+define Package/openntpd/postrm
+#!/bin/sh
+/bin/busybox ntpd -h 2>&1 | grep -q BusyBox && ln -sf ../../bin/busybox /usr/sbin/ntpd
+exit 0
+endef
+
 $(eval $(call BuildPackage,openntpd))