replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / openser / Makefile
index 696e9e692d57eec5fdd33e42495dc9ceab0f0c6b..61e1ce2538e7cba2aa788b76fe8b284d4b908571 100644 (file)
@@ -275,7 +275,7 @@ endef
 
 define BuildPlugin
   define Package/$(1)/install
-       [ -z "$(2)" ] || install -d -m0755 $$(1)/usr/lib/openser/modules/
+       [ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/openser/modules/
        $(CP) $(PKG_BUILD_DIR)/modules/$(2)/$(2).so \
                        $$(1)/usr/lib/openser/modules/ ;
   endef