[openssh]: remove obsolete lines
[openwrt/svn-archive/archive.git] / net / openser / Makefile
index 0b6e518ed267a42847d6ace2de911371638f04b8..7e26cd978577f200751346032f4e2c06af7ab7e0 100644 (file)
@@ -247,24 +247,24 @@ define Build/Compile
                extra_defs="-DUSE_PTHREAD_MUTEX "  \
                CC="$(TARGET_CC)" \
                ARCH="$(ARCH)"  \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
                LOCALBASE="$(STAGING_DIR)/usr" \
                all utils/gen_ha1/gen_ha1
 endef
 
 define Package/openser/install 
-       mkdir -p $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(CP) $(PKG_BUILD_DIR)/utils/gen_ha1/gen_ha1 $(1)/usr/sbin/openser_gen_ha1
        $(CP) $(PKG_BUILD_DIR)/scripts/sc $(1)/usr/sbin/openserctl
        chmod 744 $(1)/usr/sbin/openserctl
        $(CP) $(PKG_BUILD_DIR)/scripts/sc.dbtext $(1)/usr/sbin/dbtextctl
        chmod 744 $(1)/usr/sbin/dbtextctl
-       mkdir -p $(1)/usr/lib/openser/modules
+       $(INSTALL_DIR) $(1)/usr/lib/openser/modules
        (cd $(PKG_BUILD_DIR);\
                $(CP) $(OPENSER_MODULE_FILES) $(1)/usr/lib/openser/modules/; \
        )
-       mkdir -p $(1)/etc/openser
+       $(INSTALL_DIR) $(1)/etc/openser
        $(CP) $(PKG_BUILD_DIR)/etc/openser.cfg $(1)/etc/openser/
 endef