Disable ssp support in openssh (#3792)
[openwrt/svn-archive/archive.git] / net / openssh / Makefile
index 58609182bcd11930bbc9afb27f0f116260c7fc09..44437c44d50858217c19f47589b6bd781fd6360f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=4.4p1
+PKG_VERSION:=5.0p1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
-               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
-               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=793a709a8de695c22f523024d7e9bf07
-PKG_CAT:=zcat
+               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
+               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
+PKG_MD5SUM:=1f1dfaa775f33dd3328169de9bdc292a
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -32,8 +31,12 @@ define Package/openssh-client
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH client
-  DESCRIPTION:=OpenSSH client.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-client/description
+OpenSSH client.
 endef
 
 define Package/openssh-client/conffiles
@@ -45,8 +48,12 @@ define Package/openssh-client-utils
   CATEGORY:=Network
   DEPENDS:=openssh-client
   TITLE:=OpenSSH client utilities
-  DESCRIPTION:=OpenSSH client utilities.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-client-utils/description
+OpenSSH client utilities.
 endef
 
 define Package/openssh-server
@@ -54,8 +61,12 @@ define Package/openssh-server
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH server
-  DESCRIPTION:=OpenSSH server.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-server/description
+OpenSSH server.
 endef
 
 define Package/openssh-server/conffiles
@@ -67,8 +78,12 @@ define Package/openssh-sftp-client
   CATEGORY:=Network
   DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH SFTP client
-  DESCRIPTION:=OpenSSH SFTP client.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-sftp-client/description
+OpenSSH SFTP client.
 endef
 
 define Package/openssh-sftp-server
@@ -76,8 +91,12 @@ define Package/openssh-sftp-server
   CATEGORY:=Network
   DEPENDS:=
   TITLE:=OpenSSH SFTP server
-  DESCRIPTION:=OpenSSH SFTP server.
   URL:=http://www.openssh.com/
+  SUBMENU:=SSH
+endef
+
+define Package/openssh-sftp-server/description
+OpenSSH SFTP server.
 endef
 
 define Build/Configure
@@ -117,6 +136,7 @@ define Build/Configure
                        --disable-utmpx \
                        --disable-wtmp \
                        --disable-wtmpx \
+                       --without-stackprotect \
                        --without-bsd-auth \
                        --without-kerberos5 \
                        --without-pam \
@@ -141,15 +161,13 @@ define Package/openssh-client/install
        chmod 0700 $(1)/etc/ssh
        $(CP) $(PKG_INSTALL_DIR)/etc/ssh/ssh_config $(1)/etc/ssh/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/bin/
 endef
 
 define Package/openssh-client-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-add $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-agent $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-keyscan $(1)/usr/bin/
+       $(INSTALL_BIN) $(foreach bin,add agent keyscan keysign,$(PKG_BUILD_DIR)/ssh-$(bin)) $(1)/usr/bin/
 endef
 
 define Package/openssh-server/install
@@ -159,14 +177,54 @@ define Package/openssh-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/sshd.init $(1)/etc/init.d/sshd
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh-keygen $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/sshd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/sshd $(1)/usr/sbin/
+endef
+
+define Package/openssh-server/postinst
+#!/bin/sh
+
+name=sshd
+id=99
+
+# do not change below
+# check if we are on real system
+if [ -z "$${IPKG_INSTROOT}" ]; then
+       # create copies of passwd and group, if we use squashfs
+       rootfs=`mount |awk '/root/ { print $$5 }'`
+       if [ "$$rootfs" = "squashfs" ]; then
+               if [ -h /etc/group ]; then
+                       rm /etc/group
+                       cp /rom/etc/group /etc/group
+               fi
+               if [ -h /etc/passwd ]; then
+                       rm /etc/passwd
+                       cp /rom/etc/passwd /etc/passwd
+               fi
+       fi
+fi
+
+echo ""
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then 
+       echo "adding group $$name to /etc/group"
+       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group  
+fi
+
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then 
+       echo "adding user $$name to /etc/passwd"
+       echo "$${name}:x:$${id}:$${id}:$${name}:/var/empty/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
+fi
+
+grep -q '^ssh[[:space:]]*22/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
+if [ $$? -ne 0 ]; then
+echo "ssh           22/tcp" >>$${IPKG_INSTROOT}/etc/services
+fi
 endef
 
 define Package/openssh-sftp-client/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sftp $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sftp $(1)/usr/bin/
 endef
 
 define Package/openssh-sftp-server/install