[packages] openvpn: stop instances even if they are disabled (#9404)
[openwrt/svn-archive/archive.git] / net / openvpn / Makefile
index 7e3a7b05dfe9e49df2817c70df75ea7036dd9f73..4cf8d0eb3d0790342dd2797f78ce320e2a1b52ce 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
-PKG_VERSION:=2.1.3
-PKG_RELEASE:=4
+PKG_VERSION:=2.1.4
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
-PKG_MD5SUM:=7486d3e270ba4b033e311d3e022a0ad7
+PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases @SF/openvpn
+PKG_MD5SUM:=96a11868082685802489254f03ff3bde
 
 PKG_INSTALL:=1
 
@@ -56,6 +56,9 @@ define Package/openvpn-easy-rsa/conffiles
 endef
 
 CONFIGURE_ARGS+= \
+       --with-ifconfig-path=/sbin/ifconfig \
+       --with-iproute-path=/usr/sbin/ip \
+       --with-route-path=/sbin/route \
        --disable-pthread \
        --disable-debug \
        --disable-plugins \