Explicitely disable the use of epoll (#3703)
[openwrt/svn-archive/archive.git] / net / openvpn / Makefile
index 31da38a1895807cd3187c60b608dcd188325a6f8..9b4e12685a2992046e182db2689988d7dd4a2fb2 100644 (file)
@@ -27,7 +27,7 @@ define Package/openvpn
   DEPENDS:=+kmod-tun +libopenssl +liblzo
   TITLE:=Open source VPN solution using SSL
   URL:=http://openvpn.net
-  SUBMENU:=vpn
+  SUBMENU:=VPN
 endef
 
 define Package/openvpn/description
@@ -48,6 +48,8 @@ define Build/Configure
                --enable-management \
                --disable-socks \
                --enable-password-save \
+               ,\
+               ac_cv_func_epoll_create=no \
        )
 endef
 
@@ -59,7 +61,7 @@ endef
 
 define Package/openvpn/install 
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/openvpn $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/openvpn $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/etc/default