[net] printing: Removed printing submenu as it had only two entries.
[openwrt/svn-archive/archive.git] / net / p910nd / Makefile
index 11d4603bf9e17153aaff0905ac15189064aeed03..05f428000c2ba1190c02c8f1ff946d470ec70697 100644 (file)
@@ -1,20 +1,21 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p910nd
-PKG_VERSION:=0.93
+PKG_VERSION:=0.94
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/p910nd
-PKG_MD5SUM:=f668eace7f424953c3aa48afcb34c62b
+PKG_MD5SUM:=befca09ca3685dc3ea82473102ec8f11
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,7 +24,6 @@ define Package/p910nd
   CATEGORY:=Network
   TITLE:=A small non-spooling printer server
   URL:=http://p910nd.sourceforge.net
-  SUBMENU:=printing
 endef
 
 define Package/p910nd/conffiles
@@ -31,12 +31,12 @@ define Package/p910nd/conffiles
 endef
 
 define Package/p910nd/description
- p910nd is a small daemon that copies any data received on 
- the port it is listening on to the  corresponding printer 
- port. It  is primarily intended for diskless Linux hosts 
- running as printer drivers but there is no reason why it 
- could  not  be used on diskful hosts. Port 9100 is copied 
- to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The 
+ p910nd is a small daemon that copies any data received on
+ the port it is listening on to the corresponding printer
+ port. It is primarily intended for diskless Linux hosts
+ running as printer drivers but there is no reason why it
+ could not be used on diskful hosts. Port 9100 is copied
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The
  default is port 9100 to /dev/lp0.
 endef
 
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
 
 define Package/p910nd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/$(PKG_NAME).conf $(1)/etc/config/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/etc/init.d