p910nd: Fix init script and make use use append_bool() and appand_string() functions
[openwrt/svn-archive/archive.git] / net / p910nd / Makefile
index d3acf0d0a675b38f31f34d04f1f0d13002663c32..0de6a11d8806723ab5a8a2d5d23eff506fe5103e 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p910nd
 PKG_VERSION:=0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.etherboot.org/p910nd
 PKG_MD5SUM:=7bf752532d26c9106f8039db95df3a6b
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,37 +22,33 @@ define Package/p910nd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small non-spooling printer server
-  DESCRIPTION:=\
-       p910nd  is a small daemon that copies any data received on \\\
-       the port it is listening on to the  corresponding  printer \\\
-       port.   It  is primarily intended for diskless Linux hosts \\\
-       running as printer drivers but there is no reason  why  it \\\
-       could  not  be used on diskful hosts.  Port 9100 is copied \\\
-       to /dev/lp0, 9101 to /dev/lp1 and 9102 to  /dev/lp2.   The \\\
-       default is port 9100 to /dev/lp0.
   URL:=http://www.etherboot.org/p910nd/
 endef
 
 define Package/p910nd/conffiles
-/etc/default/p910nd
+/etc/config/p910nd
 endef
 
-define Build/Configure
+define Package/p910nd/description
+ p910nd is a small daemon that copies any data received on 
+ the port it is listening on to the  corresponding printer 
+ port. It  is primarily intended for diskless Linux hosts 
+ running as printer drivers but there is no reason why it 
+ could  not  be used on diskful hosts. Port 9100 is copied 
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The 
+ default is port 9100 to /dev/lp0.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\\\"\""
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\"\\\""
 
 define Package/p910nd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/p910nd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(INSTALL_DATA) ./files/p910nd.default $(1)/etc/default/p910nd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).conf $(1)/etc/config/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/p910nd.init $(1)/etc/init.d/p910nd
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,p910nd))