[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / net / p910nd / Makefile
index c1bce001c47a06339248dce8a42b022721686f70..1e0fafb45f9403c9b4cc19f9e9019b0a4c6e6dd7 100644 (file)
@@ -1,23 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p910nd
-PKG_VERSION:=0.7
-PKG_RELEASE:=2
+PKG_VERSION:=0.95
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.etherboot.org/p910nd
-PKG_MD5SUM:=7bf752532d26c9106f8039db95df3a6b
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/p910nd
+PKG_MD5SUM:=c7ac6afdf7730ac8387a8e87198d4491
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,37 +23,33 @@ define Package/p910nd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small non-spooling printer server
-  DESCRIPTION:=\
-       p910nd  is a small daemon that copies any data received on \\\
-       the port it is listening on to the  corresponding  printer \\\
-       port.   It  is primarily intended for diskless Linux hosts \\\
-       running as printer drivers but there is no reason  why  it \\\
-       could  not  be used on diskful hosts.  Port 9100 is copied \\\
-       to /dev/lp0, 9101 to /dev/lp1 and 9102 to  /dev/lp2.   The \\\
-       default is port 9100 to /dev/lp0.
-  URL:=http://www.etherboot.org/p910nd/
+  URL:=http://p910nd.sourceforge.net
 endef
 
 define Package/p910nd/conffiles
-/etc/default/p910nd
+/etc/config/p910nd
 endef
 
-define Build/Configure
+define Package/p910nd/description
+ p910nd is a small daemon that copies any data received on
+ the port it is listening on to the corresponding printer
+ port. It is primarily intended for diskless Linux hosts
+ running as printer drivers but there is no reason why it
+ could not be used on diskful hosts. Port 9100 is copied
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The
+ default is port 9100 to /dev/lp0.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\\\"\""
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -DLOCKFILE_DIR=\"\\\"/tmp\"\\\""
 
 define Package/p910nd/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/p910nd $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/default
-       install -m0644 ./files/p910nd.default $(1)/etc/default/p910nd
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/p910nd.init $(1)/etc/init.d/p910nd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).conf $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,p910nd))