[package] p910nd: add IPv6 support (#7646)
[openwrt/svn-archive/archive.git] / net / p910nd / Makefile
index 89148d8f5601f5f5ea1b986b2397f4df49f419b7..b4aeebeeabc8679b516e754d2fba1c3cf9ca6769 100644 (file)
@@ -1,20 +1,19 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p910nd
-PKG_VERSION:=0.7
-PKG_RELEASE:=3
+PKG_VERSION:=0.93
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.etherboot.org/p910nd
-PKG_MD5SUM:=7bf752532d26c9106f8039db95df3a6b
+PKG_SOURCE_URL:=@SF/p910nd
+PKG_MD5SUM:=f668eace7f424953c3aa48afcb34c62b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,15 +21,22 @@ define Package/p910nd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small non-spooling printer server
-  DESCRIPTION:=\
-       p910nd is a small daemon that copies any data received on \\\
-       the port it is listening on to the  corresponding printer \\\
-       port. It  is primarily intended for diskless Linux hosts \\\
-       running as printer drivers but there is no reason why it \\\
-       could  not  be used on diskful hosts. Port 9100 is copied \\\
-       to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The \\\
-       default is port 9100 to /dev/lp0.
-  URL:=http://www.etherboot.org/p910nd/
+  URL:=http://p910nd.sourceforge.net
+  SUBMENU:=printing
+endef
+
+define Package/p910nd/conffiles
+/etc/config/p910nd
+endef
+
+define Package/p910nd/description
+ p910nd is a small daemon that copies any data received on 
+ the port it is listening on to the  corresponding printer 
+ port. It  is primarily intended for diskless Linux hosts 
+ running as printer drivers but there is no reason why it 
+ could  not  be used on diskful hosts. Port 9100 is copied 
+ to /dev/lp0, 9101 to /dev/lp1 and 9102 to /dev/lp2. The 
+ default is port 9100 to /dev/lp0.
 endef
 
 MAKE_FLAGS += \