net/quagga-unstable: Enable parallel build
[openwrt/svn-archive/archive.git] / net / parprouted / Makefile
index d9456de56c31052c810776e299d2fd5a9a9e0234..4a84fe1473317999d0fcd7ce747f24d34a0ffa0e 100644 (file)
@@ -4,46 +4,51 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=parprouted
-PKG_VERSION:=0.63
+PKG_VERSION:=0.64
 PKG_RELEASE:=1
-PKG_MD5SUM:=12753098a22e82997d1941d6d2284750
 
-PKG_SOURCE_URL:=http://www.hazard.maks.net/parprouted/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.hazard.maks.net/parprouted/
+PKG_MD5SUM:=14133c9cb8dd9c9a90ff37648ae7b31a
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/parprouted
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libpthread
   TITLE:=Proxy ARP daemon
-  DESCRIPTION:=parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging.\\\
-       This is useful for creation of transparent firewalls and bridging networks\\\
-       with different MAC protocols. Also, unlike standard bridging, proxy ARP\\\
-       bridging allows to bridge Ethernet networks behind wireless nodes without\\\
-       using WDS or layer 2 bridging.\\\
  URL:=http://www.hazard.maks.net/parprouted/
 endef
 
+define Package/parprouted/description
+       parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging.
+       This is useful for creation of transparent firewalls and bridging networks
+       with different MAC protocols. Also, unlike standard bridging, proxy ARP
+       bridging allows to bridge Ethernet networks behind wireless nodes without
+       using WDS or layer 2 bridging.
+
+endef
+
 define Build/Compile
-  $(call Build/Compile/Default,CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="" all)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="" \
+               all \
+       )
 endef
 
 define Package/parprouted/install      
-       install -d -m0755 $(1)/etc/default
-       install -m0755 ./files/parprouted.default $(1)/etc/default/parprouted
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/parprouted.init $(1)/etc/init.d/parprouted
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/parprouted $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/parprouted $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_BIN) ./files/parprouted.default $(1)/etc/default/parprouted
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/parprouted.init $(1)/etc/init.d/parprouted
 endef
 
 $(eval $(call BuildPackage,parprouted))