Fix bitchx installation
[openwrt/svn-archive/archive.git] / net / parprouted / Makefile
index 7c39707f9b0328e3296419c5f3686d498948f205..e65729fbc82857189d705a9321aff835f63917da 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=parprouted
-PKG_VERSION:=0.63
+PKG_VERSION:=0.64
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hazard.maks.net/parprouted/
-PKG_MD5SUM:=12753098a22e82997d1941d6d2284750
-PKG_CAT:=zcat
+PKG_MD5SUM:=14133c9cb8dd9c9a90ff37648ae7b31a
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -24,16 +23,20 @@ include $(INCLUDE_DIR)/package.mk
 define Package/parprouted
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libpthread
   TITLE:=Proxy ARP daemon
-  DESCRIPTION:=\
-       parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging.\\\
-       This is useful for creation of transparent firewalls and bridging networks\\\
-       with different MAC protocols. Also, unlike standard bridging, proxy ARP\\\
-       bridging allows to bridge Ethernet networks behind wireless nodes without\\\
-       using WDS or layer 2 bridging.\\\
  URL:=http://www.hazard.maks.net/parprouted/
 endef
 
+define Package/parprouted/description
+       parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging.
+       This is useful for creation of transparent firewalls and bridging networks
+       with different MAC protocols. Also, unlike standard bridging, proxy ARP
+       bridging allows to bridge Ethernet networks behind wireless nodes without
+       using WDS or layer 2 bridging.
+
+endef
+
 define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -43,12 +46,12 @@ define Build/Compile
 endef
 
 define Package/parprouted/install      
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/parprouted $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/default
-       install -m0755 ./files/parprouted.default $(1)/etc/default/parprouted
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/parprouted.init $(1)/etc/init.d/parprouted
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/parprouted $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_BIN) ./files/parprouted.default $(1)/etc/default/parprouted
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/parprouted.init $(1)/etc/init.d/parprouted
 endef
 
 $(eval $(call BuildPackage,parprouted))