really set exec perm on peerguardian initscript (thanks olli for noticing)
[openwrt/svn-archive/archive.git] / net / peerguardian / Makefile
index f184dcfd7e065dfbb209356ffeb290fb774214ae..eba0b12bd902306f8c96dfde0afb77d7b688d109 100644 (file)
@@ -57,7 +57,7 @@ define Package/peerguardian/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/peerguardnf $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/pgtext $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/peerguardian.init $(1)/etc/init.d/peerguardian
+       $(INSTALL_BIN) ./files/peerguardian.init $(1)/etc/init.d/peerguardian
 endef
 
 $(eval $(call BuildPackage,peerguardian))