Update pen to 0.18.0 (#3643)
[openwrt/svn-archive/archive.git] / net / pen / Makefile
index fa4074418b2e7fb1ffaf05619c95180bfe55ed9b..5005ec671a6e91b5d69010452761ed3c2ef2c8d5 100644 (file)
@@ -4,20 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6500 2007-03-04 04:19:46Z pavlov $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pen
-PKG_VERSION:=0.17.1
+PKG_VERSION:=0.18.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://siag.nu/pub/pen/
-PKG_MD5SUM:=62548155d3bf42aea05b32227e132331
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=96f6d39e7e7cca11a647e795550f3829
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +23,17 @@ define Package/pen
   CATEGORY:=Network
   DEPENDS:=+libopenssl
   TITLE:=Simple tcp load balancer
-  DESCRIPTION:=\
-       This is pen, a load balancer for "simple" tcp based protocols \\\
-       such as http or smtp. It allows several servers to appear as \\\
-       one to the outside and automatically detects servers that are \\\
-       down and distributes clients among the available servers. \\\
-       This gives high availability and scalable performance.
   URL:=http://siag.nu/pen/
 endef
 
+define Package/pen/description
+       This is pen, a load balancer for "simple" tcp based protocols
+       such as http or smtp. It allows several servers to appear as
+       one to the outside and automatically detects servers that are
+       down and distributes clients among the available servers.
+       This gives high availability and scalable performance.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-poll \