[packages] freeswitch: Don't look for libgnutls-config. The package does not
[openwrt/svn-archive/archive.git] / net / pmacct / Makefile
index a619bafa5a84d5d942959aef39775cf1e1c65141..240acac1dddc48b1765a57129b9a2e0b7e8442d9 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,13 +12,10 @@ PKG_VERSION:=0.10.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ba.cnr.it/~paolo/pmacct/
+PKG_SOURCE_URL:=http://www.pmacct.net/
 PKG_MD5SUM:=0be1ffd9d4bda73575caa3240abbf4cb
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-PKG_BUILDDEP:=libpcap
+PKG_BUILD_DEPENDS:=libpcap
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +23,7 @@ define Package/pmacct/Default
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=pmacct (accounting and aggregation tools)
-  URL:=http://www.ba.cnr.it/~paolo/pmacct/
+  URL:=http://www.pmacct.net/
 endef
 
 define Package/nfacctd/Default
@@ -85,103 +81,105 @@ define Package/pmacctd-sqlite
   DEPENDS+= +libsqlite3
 endef
 
-define Package/sfacctd/Default
-  $(call Package/pmacct/Default)
-  TITLE:=sFlow accounting daemon
-endef
-
 define Package/pmacct-client
   $(call Package/pmacct/Default)
   TITLE:=Command-line client to gather data from the IMT plugin
 endef
 
-
-ifneq ($(SDK),)
-  CONFIG_PACKAGE_nfacctd:=m
-  CONFIG_PACKAGE_nfacctd-mysql:=m
-  CONFIG_PACKAGE_nfacctd-pgsql:=m
-  CONFIG_PACKAGE_nfacctd-sqlite:=m
-  CONFIG_PACKAGE_pmacctd:=m
-  CONFIG_PACKAGE_pmacctd-mysql:=m
-  CONFIG_PACKAGE_pmacctd-pgsql:=m
-  CONFIG_PACKAGE_pmacctd-sqlite:=m
-endif
-
 define Compile/Template
 
-$(PKG_BUILD_DIR)/nfacctd-$(1) $(PKG_BUILD_DIR)/pmacctd-$(1): $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/nfacctd$(1) $(PKG_BUILD_DIR)/pmacctd$(1): $(STAMP_CONFIGURED)
        -$(MAKE) -C $(PKG_BUILD_DIR) distclean
        $(call Build/Configure/Default, \
                --with-pcap-includes="$(STAGING_DIR)/usr/include" \
                --with-pcap-libs="$(STAGING_DIR)/usr/lib" \
-               "$(2)" \
+               $(2) \
                ,\
-               LIBS+="-lz" \
+               LIBS="-lz" \
+               ,,\
        );
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                all
-       mv -f $(PKG_BUILD_DIR)/src/nfacctd $(PKG_BUILD_DIR)/nfacctd-$(1)
-       mv -f $(PKG_BUILD_DIR)/src/pmacctd $(PKG_BUILD_DIR)/pmacctd-$(1)
+       mv -f $(PKG_BUILD_DIR)/src/nfacctd $(PKG_BUILD_DIR)/nfacctd$(1)
+       mv -f $(PKG_BUILD_DIR)/src/pmacctd $(PKG_BUILD_DIR)/pmacctd$(1)
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/nfacctd-$(1) $(PKG_BUILD_DIR)/pmacctd-$(1)
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/nfacctd$(1) $(PKG_BUILD_DIR)/pmacctd$(1)
 
 endef
 
 
 define Install/Template
 
-define Package/$(1)/conffiles
-/etc/default/$(3)
-/etc/$(3).conf
+define Package/$(1)$(2)/conffiles
+/etc/default/$(1)
+/etc/$(1).conf
 endef
 
-define Package/$(1)/install
+define Package/$(1)$(2)/install
        $(INSTALL_DIR) $$(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(2) $$(1)/usr/sbin/$(3)
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(1)$(2) $$(1)/usr/sbin/$(1)
        $(INSTALL_DIR) $$(1)/etc
-       $(INSTALL_DATA) ./files/$(3).conf $$(1)/etc/
+       $(INSTALL_DATA) ./files/$(1).conf $$(1)/etc/
        $(INSTALL_DIR) $$(1)/etc/default
-       $(INSTALL_DATA) ./files/$(3).default $$(1)/etc/default/$(3)
+       $(INSTALL_DATA) ./files/$(1).default $$(1)/etc/default/$(1)
        $(INSTALL_DIR) $$(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(3).init $$(1)/etc/init.d/$(3)
+       $(INSTALL_BIN) ./files/$(1).init $$(1)/etc/init.d/$(1)
 endef
 
 endef
 
-
-ifneq ($(CONFIG_PACKAGE_nfacctd)$(CONFIG_PACKAGE_pmacctd),)
-  $(eval $(call Compile/Template,basic))
-  $(eval $(call Install/Template,nfacctd,nfacctd-basic,nfacctd))
-  $(eval $(call Install/Template,pmacctd,pmacctd-basic,pmacctd))
+ifneq ($(SDK)$(CONFIG_PACKAGE_nfacctd)$(CONFIG_PACKAGE_pmacctd),)
+  define Compile/pmacct/basic
+    $(call Compile/Template,, \
+       --disable-mysql \
+       --disable-pgsql \
+       --disable-sqlite3 \
+    )
+    $(call Install/Template,nfacctd,)
+    $(call Install/Template,pmacctd,)
+  endef
 endif
-ifneq ($(CONFIG_PACKAGE_nfacctd-mysql)$(CONFIG_PACKAGE_pmacctd-mysql),)
-  $(eval $(call Compile/Template,mysql, \
-               --enable-mysql \
-               --with-mysql-includes="$(STAGING_DIR)/usr/include" \
-               --with-mysql-libs="$(STAGING_DIR)/usr/lib/mysql" \
-  ))
-  $(eval $(call Install/Template,nfacctd-mysql,nfacctd-mysql,nfacctd))
-  $(eval $(call Install/Template,pmacctd-mysql,pmacctd-mysql,pmacctd))
+$(eval $(Compile/pmacct/basic))
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_nfacctd-mysql)$(CONFIG_PACKAGE_pmacctd-mysql),)
+  define Compile/pmacct/mysql
+    $(call Compile/Template,-mysql, \
+       --enable-mysql \
+       --with-mysql-includes="$(STAGING_DIR)/usr/include" \
+       --with-mysql-libs="$(STAGING_DIR)/usr/lib/mysql" \
+    )
+    $(call Install/Template,nfacctd,-mysql)
+    $(call Install/Template,pmacctd,-mysql)
+  endef
 endif
-ifneq ($(CONFIG_PACKAGE_nfacctd-pgsql)$(CONFIG_PACKAGE_pmacctd-pgsql),)
-  $(eval $(call Compile/Template,pgsql, \
-               --enable-pgsql \
-               --with-pgsql-includes="$(STAGING_DIR)/usr/include" \
-               --with-pgsql-libs="$(STAGING_DIR)/usr/lib" \
-  ))
-  $(eval $(call Install/Template,nfacctd-pgsql,nfacctd-pgsql,nfacctd))
-  $(eval $(call Install/Template,pmacctd-pgsql,pmacctd-pgsql,pmacctd))
+$(eval $(Compile/pmacct/mysql))
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_nfacctd-pgsql)$(CONFIG_PACKAGE_pmacctd-pgsql),)
+  define Compile/pmacct/pgsql
+    $(call Compile/Template,-pgsql, \
+       --enable-pgsql \
+       --with-pgsql-includes="$(STAGING_DIR)/usr/include" \
+       --with-pgsql-libs="$(STAGING_DIR)/usr/lib" \
+    )
+    $(call Install/Template,nfacctd,-pgsql)
+    $(call Install/Template,pmacctd,-pgsql)
+  endef
 endif
-ifneq ($(CONFIG_PACKAGE_nfacctd-sqlite)$(CONFIG_PACKAGE_pmacctd-sqlite),)
-  $(eval $(call Compile/Template,sqlite, \
-               --enable-sqlite3 \
-               --with-sqlite3-includes="$(STAGING_DIR)/usr/include" \
-               --with-sqlite3-libs="$(STAGING_DIR)/usr/lib" \
-  ))
-  $(eval $(call Install/Template,nfacctd-sqlite,nfacctd-sqlite,nfacctd))
-  $(eval $(call Install/Template,pmacctd-sqlite,pmacctd-sqlite,pmacctd))
+$(eval $(Compile/pmacct/pgsql))
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_nfacctd-sqlite)$(CONFIG_PACKAGE_pmacctd-sqlite),)
+  define Compile/pmacct/sqlite
+    $(call Compile/Template,-sqlite, \
+       --enable-sqlite3 \
+       --with-sqlite3-includes="$(STAGING_DIR)/usr/include" \
+       --with-sqlite3-libs="$(STAGING_DIR)/usr/lib" \
+    )
+    $(call Install/Template,nfacctd,-sqlite)
+    $(call Install/Template,pmacctd,-sqlite)
+  endef
 endif
+$(eval $(Compile/pmacct/sqlite))
 
 define Build/Configure
 endef