[batman-adv] batctl replaces battool for testing / debugging / configuration
[openwrt/svn-archive/archive.git] / net / portmap / Makefile
index 4604a67b0a70db17419dea9e20d4f17fc1dd26af..5f715cc02043b389eee4c7eab5bcc774c5514e95 100644 (file)
@@ -1,23 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
 PKG_VERSION:=6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://neil.brown.name/portmap/
 PKG_MD5SUM:=ac108ab68bf0f34477f8317791aaf1ff
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(PKG_NAME)_$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,22 +23,25 @@ define Package/portmap
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libwrap
-  TITLE:=RPC Portmapper
+  TITLE:=The RPC Portmapper
   URL:=ftp://ftp.porcupine.org/pub/security
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DHOSTS_ACCESS -DFACILITY=LOG_DAEMON -DIGNORE_SIGCHLD" \
-               WRAP_LIB="-L$(STAGING_DIR)/usr/lib -lwrap" \
-               all
+define Package/portmap/description
+ Portmap is a server that converts RPC (Remote Procedure Call) program
+ numbers into DARPA protocol port numbers.
 endef
 
-define Package/portmap/install 
-       $(INSTALL_DIR) $(1)/usr/sbin 
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DHOSTS_ACCESS -DFACILITY=LOG_DAEMON -DIGNORE_SIGCHLD" \
+       RPCUSER="nobody" \
+       WRAP_LIB="$(TARGET_LDFLAGS) -lwrap" \
+       all
+
+define Package/portmap/install
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/portmap $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/init.d 
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/portmap.init $(1)/etc/init.d/portmap
 endef