replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / portmap / Makefile
index 05b19c4471daf3470217544ac6200a07a6cb212d..a86aaa4562da2a1d23b408a07aa2f207f38d6b81 100644 (file)
@@ -11,14 +11,13 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=portmap
 PKG_VERSION:=5beta
 PKG_RELEASE:=2
-PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 
-PKG_SOURCE_URL:=ftp://ftp.porcupine.org/pub/security
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.porcupine.org/pub/security
+PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +26,6 @@ define Package/portmap
   CATEGORY:=Network
   DEPENDS:=+libwrap
   TITLE:=RPC Portmapper
-  DESCRIPTION:=The RPC Portmapper (used by the NFS Server)
   URL:=ftp://ftp.porcupine.org/pub/security
 endef
 
@@ -40,11 +38,10 @@ define Build/Compile
 endef
 
 define Package/portmap/install 
-       install -d -m0755 $(1)/etc/init.d 
-       install -m0755 ./files/portmap.init $(1)/etc/init.d/portmap
-       ln -sf portmap $(1)/etc/init.d/S59portmap
-       install -d -m0755 $(1)/usr/sbin 
-       install -m0755 $(PKG_BUILD_DIR)/portmap $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin 
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/portmap $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d 
+       $(INSTALL_BIN) ./files/portmap.init $(1)/etc/init.d/portmap
 endef
 
 $(eval $(call BuildPackage,portmap))