Add missing dependency to wifidog, thanks florida (#4132).
[openwrt/svn-archive/archive.git] / net / portsentry / Makefile
index 7bcd7faab09b08e44a09fa2ff47ca0383de06f73..bbd6830e1bb4a94999f7d94ea5231487e570601e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,11 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=portsentry
 PKG_VERSION:=1.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
 
-PKG_SOURCE_URL:=@SF/sentrytools
 PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/sentrytools
+PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
 
@@ -25,7 +24,6 @@ define Package/portsentry
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Portscan protection utility
-  DESCRIPTION:=Software for protection against port scans
   URL:=http://sourceforge.net/projects/sentrytools
 endef
 
@@ -33,15 +31,15 @@ define Package/portsentry/conffiles
 /etc/portsentry.conf
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) linux
-endef
+MAKE_FLAGS += \
+       linux \
 
 define Package/portsentry/install      
-       mkdir -p $(1)/usr/bin
-       mkdir -p $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,portsentry))