portsentry:
[openwrt/svn-archive/archive.git] / net / portsentry / Makefile
index e1f77d6f4b5029d1b97cd22e1dac8c5f9f4baa15..d02a9ff4807d1c5318484fdfbad8876f463f58a9 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
 PKG_SOURCE_URL:=@SF/sentrytools
 PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
 PKG_SOURCE:=$(PKG_NAME)-1.2.tar.gz
 PKG_SOURCE_URL:=@SF/sentrytools
 PKG_MD5SUM:=3ebd3618ba9abfea2525e236bd44cebd
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
 
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_beta
 
@@ -32,12 +31,8 @@ define Package/portsentry/conffiles
 /etc/portsentry.conf
 endef
 
 /etc/portsentry.conf
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) linux
-endef
+MAKE_FLAGS += \
+       linux \
 
 define Package/portsentry/install      
        $(INSTALL_DIR) $(1)/etc
 
 define Package/portsentry/install      
        $(INSTALL_DIR) $(1)/etc