Compile options - allow pptpd to do client ip management
[openwrt/svn-archive/archive.git] / net / pptpd / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 1766509..0e5bb12
@@ -26,49 +26,23 @@ include $(INCLUDE_DIR)/package.mk
 define Package/pptpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
+  DEPENDS:=+kmod-ppp +kmod-gre
   TITLE:=PopTop pptp server
   DESCRIPTION:=PopTop pptp server
 endef
 
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --with-pppd-ip-alloc \
-       )
+$(call Build/Configure/Default, --with-bcrelay)
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+  $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
-               all install
+               all install \
+  )
 endef
 
 define Package/pptpd/install
@@ -80,14 +54,11 @@ define Package/pptpd/install
        install -m0644 ./files/options.pptpd $(1)/etc/ppp/
        install -d -m0755 $(1)/usr/sbin
        install -d -m0755 $(1)/usr/lib/pptpd
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
        $(STRIP) $1/usr/sbin/*
        $(STRIP) $1/usr/lib/pptpd/*
 endef
 
 $(eval $(call BuildPackage,pptpd))
-
-
-