add submenus to several packages
[openwrt/svn-archive/archive.git] / net / pptpd / Makefile
index cf1a1752006d87b25da9f971acc8ee128f498524..60add2bdbff5d52815f36d9d4fb41f1b14822c9b 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=pptpd
 PKG_VERSION:=1.3.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
 
-PKG_SOURCE_URL:=@SF/poptop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/poptop
+PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -28,15 +28,18 @@ define Package/pptpd
   DEPENDS:=+kmod-ppp +kmod-gre
   TITLE:=PopTop pptp server
   URL:=http://www.poptop.org/
+  SUBMENU:=dial-in/up
 endef
 
 define Build/Configure
-       $(call Build/Configure/Default, --with-bcrelay)
+       $(call Build/Configure/Default, \
+               --with-bcrelay \
+       )
 endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               COPTS="\$$$$(EXTRA_CFLAGS)" \
+               COPTS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
                all install \
@@ -44,17 +47,17 @@ define Build/Compile
 endef
 
 define Package/pptpd/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/lib/pptpd
+       $(INSTALL_DIR) $(1)/usr/lib/pptpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/pptpd.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/pptpd.init $(1)/etc/init.d/pptpd
-       install -d -m0755 $(1)/etc/ppp
-       install -m0644 ./files/options.pptpd $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/pptpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/pptpd.init $(1)/etc/init.d/pptpd
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptpd $(1)/etc/ppp/
 endef
 
 $(eval $(call BuildPackage,pptpd))