pygtk requires python 2.5
[openwrt/svn-archive/archive.git] / net / pptpd / Makefile
index 1ca2037965ca4b48d56fe7c824856c5941a74430..d57241bfa1ebb6b27c2944732f2e083fa51e0a1e 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
 PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +24,7 @@ define Package/pptpd
   DEPENDS:=+kmod-ppp +kmod-gre
   TITLE:=PopTop pptp server
   URL:=http://www.poptop.org/
+  SUBMENU:=VPN
 endef
 
 define Build/Configure
@@ -47,8 +44,8 @@ endef
 
 define Package/pptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/pptpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
        $(INSTALL_DIR) $(1)/etc