pygtk requires python 2.5
[openwrt/svn-archive/archive.git] / net / pptpd / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 6c30416..d57241b
@@ -4,22 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
 PKG_VERSION:=1.3.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
 
-PKG_SOURCE_URL:=@SF/poptop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/poptop
+PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,40 +23,37 @@ define Package/pptpd
   CATEGORY:=Network
   DEPENDS:=+kmod-ppp +kmod-gre
   TITLE:=PopTop pptp server
-  DESCRIPTION:=PopTop pptp server
+  URL:=http://www.poptop.org/
+  SUBMENU:=VPN
 endef
 
-
 define Build/Configure
-$(call Build/Configure/Default,--with-pppd-ip-alloc --with-bcrelay)
+       $(call Build/Configure/Default, \
+               --with-bcrelay \
+       )
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
+       $(call Build/Compile/Default, \
+               COPTS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
                all install \
-  )
+       )
 endef
 
 define Package/pptpd/install
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/pptpd.conf $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/pptpd.init $(1)/etc/init.d/S50pptpd
-       install -d -m0755 $(1)/etc/ppp
-       install -m0644 ./files/options.pptpd $(1)/etc/ppp/
-       install -d -m0755 $(1)/usr/sbin
-       install -d -m0755 $(1)/usr/lib/pptpd
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/pptpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
-       $(STRIP) $1/usr/sbin/*
-       $(STRIP) $1/usr/lib/pptpd/*
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/pptpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/pptpd.init $(1)/etc/init.d/pptpd
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptpd $(1)/etc/ppp/
 endef
 
 $(eval $(call BuildPackage,pptpd))
-
-
-