Various privoxy fixes:
[openwrt/svn-archive/archive.git] / net / privoxy / Makefile
index b4340b5b5d762b8e1b8cf57f1d28d8481e002dd3..7cd2f96202bd2419e576072d027a290bb8a0d8cf 100644 (file)
@@ -10,11 +10,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
 PKG_VERSION:=3.0.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@SF/ijbswa
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
+PKG_SOURCE_URL:=@SF/ijbswa
+PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
@@ -25,45 +25,25 @@ include $(INCLUDE_DIR)/package.mk
 define Package/privoxy
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcre
+  DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=Privoxy is a web proxy with advanced filtering capabilities for\\\
-       protecting privacy, modifying web page content, managing cookies,\\\
-       controlling access, and removing ads, banners, pop-ups and other\\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration\\\
-       and can be customized to suit individual needs and tastes. Privoxy\\\
-       has application for both stand-alone systems and multi-user networks.\\\
+  DESCRIPTION:=\
+       Privoxy is a web proxy with advanced filtering capabilities for \\\
+       protecting privacy, modifying web page content, managing cookies, \\\
+       controlling access, and removing ads, banners, pop-ups and other \\\
+       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
+       and can be customized to suit individual needs and tastes. Privoxy \\\
+       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
 define Build/Configure
-  (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-                autoheader && autoconf && \
-                $(TARGET_CONFIGURE_OPTS) \
-                CFLAGS="$(strip $(TARGET_CFLAGS))" \
-                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-                ./configure \
-                  --target=$(GNU_TARGET_NAME) \
-                  --host=$(GNU_TARGET_NAME) \
-                  --build=$(GNU_HOST_NAME) \
-                  --program-prefix="" \
-                  --program-suffix="" \
-                  --prefix=/usr \
-                  --exec-prefix=/usr \
-                  --bindir=/usr/bin \
-                  --datadir=/usr/share \
-                  --includedir=/usr/include \
-                  --infodir=/usr/share/info \
-                  --libdir=/usr/lib \
-                  --libexecdir=/usr/lib \
-                  --localstatedir=/var \
-                  --mandir=/usr/share/man \
-                  --sbindir=/usr/sbin \
-                  --sysconfdir=/etc \
-                  $(DISABLE_NLS) \
-                  --disable-static \
-        );
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               autoheader && autoconf \
+       );
+       $(call Build/Configure/Default, \
+               --sysconfdir=/etc/privoxy \
+       )
 endef
 
 define Build/Compile   
@@ -75,9 +55,19 @@ define Build/Compile
                install
 endef
 
-define Package/privoxy/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/privoxy 
+define Package/privoxy/conffiles
+/etc/privoxy/config
+/etc/privoxy/user.action
+endef
+
+define Package/privoxy/install
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/privoxy
+       $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
+       $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
 endef
 
 $(eval $(call BuildPackage,privoxy))