[backfire/packages] batman-adv: revert r28473, r28477 - version mismatch
[openwrt/svn-archive/archive.git] / net / proftpd / Makefile
index 1f7602fc70202ec73f39321b2650388c3ac24cd6..b5d92fd73f87af5852ceccecea5302eb36bc65ac 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,22 +8,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=proftpd
-PKG_VERSION:=1.3.2d
+PKG_VERSION:=1.3.3e
 PKG_RELEASE:=1
-PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
-PKG_MD5SUM:=0941935e30199a3f22f7225fe76bc489
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_INSTALL=1
+PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
+PKG_MD5SUM:=acc49b6589bc8c9fdf1dce9000bebdbd
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/proftpd
-  SUBMENU:=FTP
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
   TITLE:=ProFTPD FTP server
   URL:=http://www.proftpd.org/
+  MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
 endef
 
 define Package/proftpd/conffiles
@@ -43,7 +46,10 @@ CONFIGURE_ARGS += \
 
 define Package/proftpd/install
        $(INSTALL_DIR) $(1)/etc
+       $(if $(CONFIG_IPV6),,$(SED) 's/^UseIPv6/#UseIPv6/' $(PKG_INSTALL_DIR)/etc/proftpd.conf)
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/proftpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/proftpd.init $(1)/etc/init.d/proftpd
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ftp{count,top,who} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin