[packages] prosody: add missing dependency on libopenssl, bump release number
[openwrt/svn-archive/archive.git] / net / prosody / Makefile
index 38dac00..a6ed1eb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
 PKG_VERSION:=0.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source/
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/prosody
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblua +libidn +luasocket +luaexpat +luasec
+  DEPENDS:=+liblua +libidn +libopenssl +luasocket +luaexpat +luasec
   TITLE:=XMPP server
   URL:=http://prosody.im
 endef
@@ -48,8 +48,8 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default,\
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX="/usr" \
                all install \