[packages] prosody: add missing dependency on libopenssl, bump release number
[openwrt/svn-archive/archive.git] / net / prosody / Makefile
index 6d25bfc301b020e3d55a8eb57e9efb0a9c419493..a6ed1eb6a6c8a94e677a3a7106fc8b76ad2d46ee 100644 (file)
@@ -8,19 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
-PKG_VERSION:=0.3.0
-PKG_RELEASE:=1
+PKG_VERSION:=0.4.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source/
-PKG_MD5SUM:=97b19d75b3d6770fb9b46b6452f945dd
+PKG_MD5SUM:=c143532a289a72d5d48b81b5bdac7c25
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/prosody
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblua +libidn +luasocket +luaexpat +luasec
+  DEPENDS:=+liblua +libidn +libopenssl +luasocket +luaexpat +luasec
   TITLE:=XMPP server
   URL:=http://prosody.im
 endef
@@ -36,10 +36,11 @@ define Package/prosody/conffiles
 endef
 
 define Build/Configure
+       # this is *NOT* GNU autoconf stuff
        (cd $(PKG_BUILD_DIR); ./configure \
                --prefix=/usr \
                --with-lua="$(STAGING_DIR)/host/bin" \
-               --with-lua-include="$(STAGING_DIR)/usr/include/" \
+               --with-lua-include="$(STAGING_DIR)/usr/include" \
                --with-lua-lib="$(STAGING_DIR)/usr/lib" \
                --cflags="$(TARGET_CFLAGS)" \
        )
@@ -47,8 +48,8 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default,\
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX="/usr" \
                all install \
@@ -56,7 +57,7 @@ define Build/Compile
 endef
 
 define Package/prosody/install
-       $(INSTALL_DIR) $(1)/
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef