[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / psybnc / Makefile
index edf145a7c27888709c4b17438a8ae4f3b484e8a7..f26497135772689fa5ff8cafebfc71e364d4a26d 100644 (file)
@@ -4,16 +4,15 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=psybnc
 PKG_VERSION:=2.3.2-7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=psyBNC-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.psybnc.info/download/beta/
+PKG_SOURCE_URL:=http://www.psybnc.at/download/beta/
 PKG_MD5SUM:=4b893a92f914813450e0921b2894ad6c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -24,9 +23,8 @@ define Package/psybnc
   SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
   TITLE:=An IRC-Bouncer with many features
-  URL:=http://www.psybnc.info/
+  URL:=http://www.psybnc.at/
 endef
 
 define Package/psybnc/description
@@ -37,6 +35,12 @@ define Package/psybnc/description
        functions are included.
 endef
 
+ifneq ($(SDK)$(CONFIG_BIG_ENDIAN),)
+  ENDIANESS:=1
+else
+  ENDIANESS:=0
+endif
+
 define Build/Compile   
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -45,6 +49,10 @@ define Build/Compile
        )
 endef
 
+define Package/psybnc/conffiles
+/etc/psybnc.conf
+endef
+
 define Package/psybnc/install  
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/psybnc.sh $(1)/usr/sbin/psybnc
@@ -53,6 +61,8 @@ define Package/psybnc/install
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/usr/share/psybnc/
        $(INSTALL_DIR) $(1)/usr/share/psybnc/lang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/lang/english.lng $(1)/usr/share/psybnc/lang/
+       $(INSTALL_DIR) $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/psybnc.conf $(1)/etc
 endef
 
 $(eval $(call BuildPackage,psybnc))